Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Now on Google Play Sticky

A topic by technicat created 25 days ago Views: 34 Replies: 14
Viewing posts 1 to 4
Developer

https://play.google.com/store/apps/details?id=com.technicat.talkdimsum

Hi , first off, I tried to email help@talkdimsum.com and it failed - relay access denied. 

Here is the content of my original email


Hi,  Just downloaded your Talk Dim Sum app and it looks great.   I do have problems with the microphone .  When I click on the icon to talk, it doesn't react.   I tried both options of 'Allow only while using the app' and 'Ask every time'

I am using a Samsung Note10+ , Android version 11.  

Thanks!


I really appreciate the effort you're putting in this app.

Developer

Thanks for reaching out (and also downloading the app!). I'll check it out. The Android version is not quite as polished and tested as the iOS version (on iOS, the speech recognition feature is part of the "Dim Sum Pro" in-app purchase, but I'm less confident it works everywhere on Android).

Developer

I fixed the email. I must have forgotten to set it up after moving talkdimsum.com to a new registrar. I was wondering why I wasn't getting the spam I usually get from publishing on Google Play! (Apple doesn't require apps to have support emails publicly listed, but Google does).

Developer

I just tried it on my Samsung Galaxy S8 (running Android version 9) and it works (though could be a bit more polished, like that timeout error message), also checked in Settings->Apps to see what the permissions looked like. Maybe there's an issue with later versions of Android, I'll let you know.

OK, I just





I asked my wife to download the app and it works for her.  She has a Note9+ and running Android v10.  Her permissions looks the same as your screenshots.  My permission settings are a little different.   It asks you to either enable microphone while app is in use, ask every time or deny.  See attachment. 

Developer

Thanks for the info, good to know it's specific to Android 11. I tried it out on an emulator in Android Studio running Android 11 and saw the same permissions request

https://developer.android.com/about/versions/11/privacy/permissions#:~:text=One-time%20permissions%20Starting%20in%20Android%2011%2C%20whenever%20your,your%20app%20is%20granted%20a%20temporary%20one-time%20permission.

and in the emulator the speech-to-text failed with a debug message saying the device has no speech recognizer, which at first I assumed was because it was an emulator, but I found a related thread for the speech-to-text plugin I'm using with some possible fixes.

https://github.com/csdcorp/speech_to_text/issues/159

Interesting..  that would explain why there is no reaction when I press the microphone button 

Developer

I tried out the Android Manifest fix (adding the queries section) in the emulator and it still doesn't quite work, displays an 'error - permission true' message (which doesn't really look like an error), but I uploaded the build here and to Google Play (the update should show up in a few hours), also added a shortcut to Settings in the top left menu. In the meantime, this is a good excuse for me to shop around for a newer Android device...

Just tried the latest update,  it looks like it works for the most part.   There is an odd error message when I speak quickly,  error_match_match = true (see 3rd image).   Maybe it picked up a sound but can't interpret it.   

Also,  for the changing speed bar, it doesn't seem to slow down very much even if I have it toggled all the way to the left.. seems like it slows by only 5% or so.


Developer

I still don't see it working in the emulator, seems confused about the permissions, but good to know it's basically working now on real devices. I'll have to clean up that error display: it should translate all those cryptic error messages into something understandable. I'll look at the speed slider. Thanks for the bug reports!

No problem.  To be honest it sounds like normal speed is almost all the way to the left so all you can do is speed it up faster.   See picture for where the bar is at to get normal speed.   

Developer

That's strange, for me it sounds pretty slow with the slider that far left, doesn't really sound normal until around the 25% mark.

I'm not sure if it comes out different on my phone but either way, considering most people would be looking to slow down the speech and not speed it up, I would think the normal speed should be at around the 75 or 80% mark.  Just a thought. 

Thanks

Developer

Good point. On the iOS version, I was prompted to speed up the playback from native Cantonese speakers who complained it sounded weird, but like you say, they/re not the target market! So I was shooting to have normal speed at the halfway mark (but have the default around the 25% mark for learners), but actually it does sound a bit fast to me there, and this post indicates it needs to be adjusted by .8 https://github.com/dlutton/flutter_tts/issues/109