🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Feedback & Bugs Sticky

A topic by Zaphyk created 32 days ago Views: 253 Replies: 22
Viewing posts 1 to 9
Developer (Edited 1 time)

Post here your feedback and bugs or through any of the official channels!

Please include the following items:

  • Computer specs
  • if it's a crash, include the log.txt file
  • Detailed description or screenshot of the problem

Game doesn't let me create a character. When I hit new run it just zooms in on the campfire and sits there. :(

Developer

Sorry for the issues, can you show me a screenshot of it? Do you have this button?

I get the following error when I try to run the game. It gets to the small page with the Launch button, but then it crashes and the command line opens up and says this:

Unhandled Exception: System.IO.IOException: Cannot create a file when that file already exists.

   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.__Error.WinIOError()
   at System.IO.File.InternalMove(String sourceFileName, String destFileName, Boolean checkHost)
   at System.IO.File.Move(String sourceFileName, String destFileName)
   at LauncherUpdater.Program.Main(String[] args)

Developer

Try running the game with admin privileges

I tried it. The small page seemed to stay open for a slight bit longer, but it nevertheless crashed, with the same error. Does it have something to do with my system? I'm running Windows 10.

Developer

I don't think so it must be a problem on my end. Please tell me which files you have in the folder and if you are using the itch app

I am not using the itch app. In the folder (after I ran the EXE and it crashed with the error mentioned before), I have db2.dat, ICSharpCode.SharpZipLib.dll, logo.png, notes.txt, tmp.dat, and Updater.exe.

Developer

Okay seems like a bug on my end. I uploaded the standalone version of the game so no launcher is needed but you will have to update the game manually until I fix this issue. Tell me how it goes

When I try playing it launches and then everything is white except the characters and the words

Developer

What are you pc specs? also send me your log.txt file

I get an unhandled exception dialog. The details are:

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.FormatException: Input string was not in a correct format.
   at System.Number.ParseDouble(String value, NumberStyles options, NumberFormatInfo numfmt)
   at System.Double.Parse(String s, IFormatProvider provider)
   at Launcher.MainForm.MainFormLoad(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.2101.1 built by: NET47REL1LAST
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
Hedra Launcher
    Assembly Version: 1.0.6059.39508
    Win32 Version: 1.0.6059.39508
    CodeBase: file:///C:/Users/cutle/Downloads/Project%20Hedra/Hedra%20Launcher.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.2094.0 built by: NET47REL1LAST
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.2093.0 built by: NET47REL1LAST
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.2046.0 built by: NET47REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.2046.0 built by: NET47REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.2099.0 built by: NET47REL1LAST
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.7.2046.0 built by: NET47REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


Windows 10 64bit. Not using the Itch.io app, but I might download it and try it with that.

Developer

This is when executing the Hedra Launcher.exe right? I just uploaded the standalone version of the game so try running that and tell me how it goes

When playing the game as a warrior character whenever I swing my sword and or just move around all of the textures glitch around and I cant see

Developer

Can you send me a screenshot of what is happening?Also give me your computer specs and log.txt file.

Log:

Available Devices:
{X=0,Y=0,Width=1366,Height=768}
Creating the window on the Primary Device at 1366x768
OS = Microsoft Windows NT 6.2.9200.0
CPU = AMD64 Family 22 Model 48 Stepping 1, AuthenticAMD
Graphics Card = AMD Radeon(TM) R4 Graphics | 4.5.13399 Compatibility Profile Context 15.201.1101.0
Settings: Autosave=True
LOD=True
ChunkLoaderRadius=48
InvertMouse=False
MouseSensibility=1
SSAO=True
HideObjectives=False
ShowTargetedMobs=True
ShowChat=True
ShowMinimap=True
m_Bloom=False
m_DynamicFog=True
m_AntiAliasing=4
m_FullScreen=True
MusicVolume=0.4
SFXVolume=0.1
ShadowQuality=1
VSync=True

Resolution changing was Successful.
Assets loading was Successful.
Settings loading was Successful
Loading Game Scene...
World Created Successfully!
UI was created Successfully
Player Created Successfully!
Added Generation Queue
Setted up GUI
Created GUI Notification Successfully
Scene loading was Successful.
Supported GLSL version is : 4.40
Max color samples = 8 Max depth samples = 8

<font>
</font>

<font>Specs:</font>

<font>Processor: AMD A6-3610 APU with Radeon R4 Graphics 1.80 GHz</font>

<font>Installed RAM: 8.00GB (6.95 GB Usable)</font>

<font>Windows 10 Home Edition 64 bit x64-based Processor</font>

<font>
</font>

<font>Also I found that the glitches happened the most when I was near animals (as you can see) and it was glitch before I died aswell as after</font>

Developer

I see, it seems to be a graphical bug the game has with AMD. Is this happening in the menu?Can you see the terrain?

Also I don't know what all that font shit is

PC specs:

CPU: Intel Core2 Quad Q9550

RAM: 8GBs

GPU: GT 730 (2gbs of GDDR5)


Crash Log:

System.ArgumentException: Destination array was not long enough. Check destIndex and length, and the array's lower bounds.
   at System.Array.Copy(Array sourceArray, Int32 sourceIndex, Array destinationArray, Int32 destinationIndex, Int32 length, Boolean reliable)
   at System.Collections.Generic.List`1.ToArray()
   at Hedra.Engine.Rendering.ChunkMesh.BuildFrom(ChunkMeshBuffer MeshBuffer, VertexData Data, Boolean ExtraData)
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
[FAILURE] OUTOFMEMORY
System.OutOfMemoryException: Out of memory.
   at System.Drawing.Bitmap.LockBits(Rectangle rect, ImageLockMode flags, PixelFormat format, BitmapData bitmapData)
   at System.Drawing.Bitmap.LockBits(Rectangle rect, ImageLockMode flags, PixelFormat format)
   at Hedra.Engine.Recorder.SaveScreenshot(String Path)
   at Hedra.Engine.Player.MovementManager.OnKeyDown(Object sender, KeyboardKeyEventArgs e)
   at Hedra.Engine.Events.EventDispatcher.OnKeyDown(Object sender, KeyboardKeyEventArgs e)
   at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
   at OpenTK.NativeWindow.OnKeyDown(KeyboardKeyEventArgs e)
   at OpenTK.NativeWindow.OnKeyDownInternal(Object sender, KeyboardKeyEventArgs e)
   at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
   at OpenTK.Platform.NativeWindowBase.OnKeyDown(Key key, Boolean repeat)
   at OpenTK.Platform.Windows.WinGLNative.HandleKeyboard(IntPtr handle, WindowMessage message, IntPtr wParam, IntPtr lParam)
   at OpenTK.Platform.Windows.WinGLNative.WindowProcedure(IntPtr handle, WindowMessage message, IntPtr wParam, IntPtr lParam)
   at OpenTK.Platform.Windows.Functions.DispatchMessage(MSG& msg)
   at OpenTK.Platform.Windows.WinGLNative.ProcessEvents()
   at OpenTK.NativeWindow.ProcessEvents(Boolean retainEvents)
   at OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second)
   at Hedra.Program.Main(String[] args)


What happened:

Well I was at the village (the one you go to within the first few quests) and I was fight a bandit and some how while fighting it I ended up quite littarly stuck inside of a tree I was unable to get out of it. So I tried to get a screenshot of it so I can report it as a bug (which is anothing thing you should fix, honestly dunno how I got stuck in it I just know I was fighting a bandit near a tree and ended up getting stuck in it by running into it) anyways, So I tried taking a screenshot and the error above this showed up and then the game crashed


(Also I dunno if this is suposed to happen when saving it doesnt save the spot where you were at nor does it save what quests you have completed)

Developer

Thanks for the detailed report, I really appreciated it. Can you send me your settings.cfg file? 

I am aware of the collision bug and I will be trying to refine it in the following days with a new update so dont worry.

So this are my PC specs and heres a video:

Developer

Thanks for the detailed report, but one thing is missing, what is your GPU?

GPU is in my processor its build in