🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Bugs (or not) found on patch v0.36.1

A topic by Angel Phenix created 31 days ago Views: 78 Replies: 2
Viewing posts 1 to 5
(Edited 6 times)

Posted on (DD.MM.YYYY) : 19.07.2017
Updated on (DD.MM.YYYY) : 27.07.2017 : v.0.37 Available

First of : I'm a big fan of this game already. I played lots and lots of hours. Way more than I thought was possible seeing the content of the game for now. So, you know, cheers to Steve Forde for this game and thank you for the awesome sets of hours I've played. Second : I'm really sorry if my english is bad by any way. It's not my native language and I'll still try my best to avoid dumb mistakes so your eyes won't bleed "that" much. Third : Steve, I'm really sorry for all the things I'm gonna list right now. I know developping a game can be frustrating since when you get some content there's a lot of bugs coming to you ! I'm just trying to make the bugs note easier for you to read so you'll be faster. Consider me like a.. Beta tester, I guess.

============== Real bugs / Unintended things (I guess?) ==============

1 ) There is a possibility to have infinite oxygen with two modules.

Take two modules. Put it on the ground so it'll build automatically. Step on it when the jauge isn't full yet and watch your character "appear" inside the module when it's built.  Thing is : A module is created with oxygen in it. Which means you just have to build the module, step on it (no need to get an entrance), change "room" (go to the other module) and you'll consume the oxygen created when built.  Want to come out ? Right click. Repeat this step : You don't even need a base to survive when it comes to oxygen !  Just two simple modules. And it's working with every module in the game.


2) Sound and Animation doesn't stop when you click on the ESC key.

Now this one is not game-breaking. It's nothing much to be honest.
Mine something with the shovel or the Jackhammer then press ESC, you'll hear the sound again and again and again and aga... If you're attentive enough, you'll even see the character continuing the animation over and over again. Which is quite normal since the animations doesn't stop when you press this key (Even if the game time does)
You can do the exact same thing when in the buggie. Ride the vehicule, when in acceleration, press the ESC key and the acceleration sound will continue like the other sounds.


3) "Badly" linked modules are upgrading the oxygen amount.


I know it sounds awfull but I don't know how to formulate my sentence in another way. Let me explain it to you :
In this game, buildings placed on the ground serves as a "link" to one another.
If you put a module, a solar pannel, then another module (In a line, so the two modules are not directly connected), the three buildings are considered "linked" on an electricity level. Which kinda makes sense.
The problem is, it's "linked" on the oxygen level too. 
Where it makes sense to link things, if a module alone (closed) is placed in front of a solar panel : The two are connected. But if you place the second module in front of the solar panel (the other way around, like I tried to explained), the two modules, not being connected to one another shouldn't upgrade the oxygen level like it's connected.
It's probably not a bug so I might just wait for Steve's response and delete this "bug". It just doesn't make much sense to me.



4)  Power Switch working like it's intended ? Or not ?

I'm actually just asking the question because it goes with my "3)" bug reported. 
When you link things with the power switch, then deactivate the circuit : Sure, you don't use any electricity to power up the modules on the other side of the Power Switch but you don't have the oxygen either.
It's like you totally got rid of all the modules at once. Like you displaced them when you right click on it. 
It kinda makes sense that the "total" oxygen is cut off if you turn the switch off. What doesn't makes sense is that the maximum oxygen is going up, even if it's only linked with a "POWER" switch. Just like with a solar panel, a GTR, a repair drone, etc.


5) Electricity is not needed on the water supplier.

Now, I have to be honest, this one's a little tricky. I found it only because I didn't have the electricity generation needed to maintain my whole base. Let me explain it a little more clearly :
It was the night, I turned on two of my buildings to craft metal plates. It got rid of my water suppliers which had water in it. (When I say "got rid" it's just that these weren't getting electricity anymore)
At this point, I thought it messed up my water amount because the water displayed on my screen when in the base was actually going down, just like when the plant is getting water. I was thinking my water went nowhere, until I realised that : The only thing that needs electricity is the Plant module. Which.. Doesn't really makes sense to me.
Either it should be the water supplier (The building needs a motor to send water, meaning it needs electricity) and the plant is just.. A plant module. (I would understand that it needs electricity too though, since it's on another planet and the plant has to be maintained in a certain way to be able to grow.)



6) Really Difficult to enter the buggie by clicking on it if you have a "placing building" selected in your inventory.

I know there's a keybinding to enter the vehicule, don't get me wrong. But since I always play "the fastest way", I tend to just let my fingers on the WASD keys and click on the vehicule.
When you have something to place selected (Pavement, Buildings, etc) you actually had a loooot of trouble to enter the vehicule when clicking on it. 


7) Repairing manually is.. weird ?


 [Fun fact(ornot): When I started, I thought you litterally had to get rid of the building, then place it again to "repair" it :D] 
I know It's redondant but again : I don't know if it's intended or not :
When you want to manually repair something (By left clicking on it) it takes the time the module normally takes you to interact with it.
I know this sentence can be quite weird so let me explain. When you want to open your base entrance (if it's not the automatic one) you have to click on it. When you click on it, there's a delay, a jauge getting completed. This "timer" is applicable on the repair too.
When your entrance has an air leak and you want to click on it to repair it : It doesn't repair it instantly like the normal module or the "chest" module. It takes some time. Same thing for the Medbay. When you use the Medbay, the delay is quite long. Well, to repair it, you have to wait this exact time too, like you were using the medbay.
(To be honest : It kinda makes sense that it doesn't need the same repair time depending on the module so...)

8) When you activated your torch, being real close to a rock, the light pass through it.

This "bug" happens only if you are "under" the rock, facing the north direction. When you do it in every other directions there's absolutely no problems but when you come up close to a rock being under it, you'll see the beam of light having the same behavior than normally.


9) Water being used by being "wasted".

This one is quite difficult to explain in depth so I'm gonna do it the fast way, hoping it'll be understandable.
The plant modules needs oxygen (electricity, since it comes from air converter) and water (coming from a water dispenser is better than manually placing it so I'm gonna assume we're talking about a water dispenser).
The problem is : if the plant module has a seed, isn't getting any oxygen and is connected to a water source : The water will go down without the seed growing, even a little bit.
I don't know if it's intended or not but if it is, you should probably warn the player beforehand because I probably lost a good 150+ ice patch on this bug :D

10) Cargo Container / Indoor Storage cannot store items that are already in there if it's full.

I think this bug is quite known right now so I won't really explain it.
If the "chests" are full, already containing an item you want to deposit to stack it in : It won't. Telling you the storage is full already.
To resolve it, you have to click on the item to stack it on yourself before putting it inside the storage again.


11) Cannot craft items if your inventory is full.

If i'm not mistaken, this bug is known already too.
Have a full inventory, try to craft (I tried with "Indoor Storage") and it will say that you cannot get another item on yourself while the item isn't even crafted yet.



============== SOLVED ISSUES ==============
Solved from patch v0.37 :
- The healing animation on the buggie is bugged.
- Rootseed in a Plant module have the "wrong sprite".
- Repair drone doesn't need electricity to work when placed.
- Repair drone sounds when activating.
- Repairing an auto-airlock by stepping in it.



Gonna Edit this post if I ever find something new or if something's been fixed.

Developer(+1)

Wow, thanks for this write-up. Was a big help in solving some of these bugs :)

I managed to fix some of these issues in the v0.37 update last night. Most of the others are definitely valid issues - they'll just take longer to figure out how to fix.  I'll probably write a post about power/water/air transferring between bases more at some point - since that'll require a pretty big change.

Cheers!

Now that's some really fast work ! I'm glad I could help and I hope these issues won't be a pain to be solved.
I updated the post to delete the fixed bugs so you'll be able to have a "Real-Time" bug list as long as its not fixed.
I guess you can already edit it since you're the developer but if you want me to delete things in it because you're not planning on changing it, just let me know :D
Great patch dev'!

[Edited the post.]