Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Asset Forge

Create your own 3D models and 2D sprites! · By Kenney

Custom Tiles under MacOS are not loaded.

A topic by infinitespace-studios created Jul 14, 2017 Views: 671 Replies: 18
Viewing posts 1 to 18
(1 edit) (+4)

Adding custom tiles to a folder under the Collections folder (after extracting the zip) do not show up in Asset Forge. 

The ReadMe states it should be in the Collections folder next to the executable or app. However this does not appear to work. I assume they are not supposed to be in the .app folder itself? 

You need to make a sub directory within the Collections folder, so /Collections/Interior/chair.obj will load into Asset Forge under a new category of Interior, but /Collections/chair.obj will not load


I have a same problem.

not resolved  I've tried it though.

I've tried all pattern below. but it didn't work.

  • /Applications/assetforge-mac/Collections/custom/aaa.obj
  • /Applications/assetforge-mac/
  • /Applications/assetforge-mac/
  • /Applications/
  • /Applications/

same, I have tried putting files in a subfolder in collections and they do not appear in the app. 



I would expect Antiquity to appear in the same place as Aircraft/City etc.

I just tried myself and these were loading just fine;

What version of Asset Forge are you using? Do you use the app? If so, have you tried uninstalling and installing again?

(2 edits)

I have the same issue with both 1.1.1 and 1.2.0 using Mac OS Sierra 10.12.5.

Edit: I tried installing using the app and custom collections seem to be working as expected, so it looks like this is only an issue if you download and unzip Asset Forge manually.

I am running 1.2.0 (beta) here. I downloaded the zip manually and just extracted it. I have not used the app.

This seems to be fixed in 1.2.1 . 

Thanks Kenney.

Oh really? That's awesome, I was really pulling hairs here of what it could be. Glad to hear it's solved :)

(1 edit)

I agree, I bought the license from the Asset Forge website, got install link, downloaded to the mac, unzipped automatically (in Downloads folder), downloaded custom blocks folder, moved it to Asset Forge collections folder (in Downloads). restarted Asset Forge, and did not found the custom blocks....

I then read this thread, downloaded itch app, installed Asset Forge via itch, added custom folder, bla bla bla, and it worked.  So I guess there is a bug for onboarding custom blocks without using the itch app, what I think most of us will do...

Good app anyway! thanks!

I guess permissions??

Yup, this is still an issue.  I bought Asset Forge today, downloaded the zip and ran into the same issue.  Also fixed by downloading through the itch app. 

The problem seems to be that in the direct zip download all the files and directories have the symbolic link indicator.  Not sure how that has happened but there's clearly a problem with the direct download zip. The zip downloaded from within the itch app does not have this issue.  Here's the direct download zip content's "ls -al" output:

drwxrwxrwx@  3 radar  staff    96 26 Aug 19:01

drwxrwxrwx@  3 radar  staff    96 26 Aug 20:00 Collections

drwxrwxrwx@  8 radar  staff   256 26 Aug 19:01 Samples

-rw-rw-rw-@  1 radar  staff   451 15 Jul 15:26 license.txt

-rw-rw-rw-@  1 radar  staff  1141 15 Jul 15:26 readme.txt

That's really strange, I'll have a look into this. For now, indeed use the app but we'll get it fixed so you don't have to install through Stay tuned for a fix!

(5 edits)

Hey everyone, i picked up AssetForge today and I ran into this problem (great product by the way!). I noticed unzipping and trying custom content didn't seem to work. I now think (theory) its because of macs new "App Translocation" security measure. Apps that aren't signed properly through the app store seem to be copied to a temp location and run from there instead to avoid vulnerabilities. But when it does this it only copies the .app and not folders alongside it, which would mean when it runs from this "virtual" location it doesn't have the collections folder. 

Running from the Itch app works fine, but running the file directly is when it copies and runs from the virtual location. I noticed it when i hit "Open" from AssetForge, the directory I started in wasn't right.

I'm getting same issue, and this could be the source of the problem. In the Player log I get this stack trace.

DirectoryNotFoundException: Directory '/private/var/folders/14/5j4jtjbd767d6rpl1nk05vdm0000gp/T/AppTranslocation/1A217DC0-8197-4AB1-A430-382C54AE881E/d/Collections' not found.
  at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000] in <filename unknown>:0 
  at System.IO.Directory.GetDirectories (System.String path, System.String searchPattern) [0x00000] in <filename unknown>:0 
  at System.IO.DirectoryInfo.GetDirectories (System.String searchPattern) [0x00000] in <filename unknown>:0 
  at System.IO.DirectoryInfo.GetDirectories () [0x00000] in <filename unknown>:0 
  at (wrapper remoting-invoke-with-check) System.IO.DirectoryInfo:GetDirectories ()
  at toolbox.Start () [0x00000] in <filename unknown>:0 

(1 edit)

Same for me, unzipping download and running from applications - the collections won't work. Running from itch app works fine however. By the way TinkerCad objects upload properly but have to be created very small  - 1 unit across

Running without problems here and without itch app.

Hi, I would like to report this bug again, I can't load  the collection on my mac, I have tried all what is suggested here, can the support  team guide me to make it work please ? 

I'm using 1.3 beta on MacOS Mojave and the direct download will not load custom assets. Just wanted to let you know it appears to still be a problem.

Yep we're aware of this issue, will be fixed in the new release.