Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Bug Reporting Sticky

A topic by Partysofa created Jul 14, 2017 Views: 113 Replies: 20
Viewing posts 1 to 7
Developer

If you've encountered a bug somewhere in Tales, please write about it here. Thanks for your help!

I don't know if this counts as a bug but, I'm using an xbox one controller and I can't fight. I've tried mouse and keyboard too, I just can't seem to figure it out! The game is super cool though, any help is much appreciated.

Developer

Do you have a weapon equipped? You can't fight unarmed (yet). If you have a weapon equipped, the default button for attacking with a gamepad is B. You can also try changing the controls in the starting menu.  The control name for it should be Use Item.   

Thanks for bringing it up! I'm glad you're enjoying the game :) Let me know if any of these worked for you. 

I ended up figuring it out. I had the sword from my blacksmith father equipped, but for some reason it wouldn't let me use that to attack. That's okay though, I bought an iron sword for super cheap and it worked. Thank you for the help!

Developer

I took a look at the item, and yeah it turned out it didn't have the right values applied to it, so it would not do any kind of damage or be able to hit enemies. I've fixed it now :) 

awesomesauce! I hate to bother you, but there is one other thing that makes game play a bit troublesome. This might just be my pc acting up, but every few minutes I get this thing where the game will freeze and the music will keep playing. I'll wait a few seconds and then the screen will turn white. I don't know if this has already been figured out, or if it's just my computer being annoying, but it would be awesome if it could be figured out because my personal solution is just constantly restarting the game. Thank you so much for your help!

Developer (1 edit)

I'm aware of one instance where that can happen, though for me the game just crashes and doesn't go white because debug mode. 

 Is it usually around morning time in-game? The notice boards sometimes break and endlessly loop when the game tries to update and generate new messages for them.  Approximately how long are you able to play before this happens?


Edit: it's not bothering me, don't worry about that! I'm deeply appreciative that you're letting me know about these things!

yes! It's just turning morning, I'm in midforest, I've got an error that says the estate agent is nonexistent, and I just walked out of a shop. It ran for maybe 5-10 seconds of gameplay.

Developer

Fixed Estate agent error. Looking into the crash now.

Developer

The crash has been fixed!

omg, awesome! Thank you so much! I love playing this game, that bug just made it a little challenging. This is awesome!

Developer

I've uploaded a fix for your issues now, should let you play for longer than 5 minutes at a time.

I've got a new one for you, during trade when I buy and sell things it doesn't add the number of gold that the item is worth. So if I'm buying a 12 gold sword, it will give the merchant around 1,000 gold. But if I sell something, it gives me the proper amount and takes away around 1,000 from the merchant until it gives them -399 or -899 gold and says they don't have enough. It's not a major thing, but it gets confusing from time to time. Great work on the crash patch btw, it runs perfectly now!

Developer

Fixed, was a leftover variable from the shop and inventory interface merging. Thanks!

One more small thing, I'm doing the quest called "The Cave" at the North Outpost and I can't actually enter the cave. There's a sign that reads "Do not enter, by order of Comander Dellri." That's blocks the entrance of it. (Sorry, I feel like I'm overloading you with bugs.)

Developer

There's no such thing as overloading me with bugs! Those quests are in dire need of a refresh, thanks for letting me know! I'll get that fixed soon. 


Keep'em coming!

Okay, I snagged a few of them this time. Muladin, the guy that hangs out at the docks east of the abandoned Cafror fort. He asks for rope, but when you get some he has no reaction to you activating him. The next thing, when you get to the south outpost doing those primary quests, the third one gets started but has no information in the quest log. It has no name or info, it's just blank. Next, the Stonehaven furniture merchant is giving an error every time I walk in/activate them. Then lastly, after around 2 days the notice boards stop refreshing and just show up with errors. Sorry, that's a lot, but I've been playing all day cause I love it. I just noticed these few things.

Developer

Thank you! I'll look into them.

midforest guard, when i talk to him i get" critical error #11- an eternal error occurred with the basic map construction help us help you, by reporting the problem. Either inform..." i have to restart the game when i get that

Developer

I'm unable to reproduce this error and see nothing in the code that should make the game crash that hard :/ Does it happen consistently/every time you try talking to him?

You should be able to close the game from the Task Manager if it crashes, I'm sorry that you had to go through the trouble of rebooting your computer because of it! I know how much of a hassle it is.

oh yea when i get that i also cant close the app so i have to do other stuff with that as my background or just restart my computer