🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Can't get Custom blocks to work

A topic by Teddyoh created 44 days ago Views: 127 Replies: 9
Viewing posts 1 to 4

Can't for the life of me figure out how to export the models created in Cinema 4D properly, whatever is exported seems to just be empty when opening it in Assetforge. 

Screenshot of a square.

Square .OBJ file

It seems like your box is incredibly large and is simply too large to display in Asset Forge, make sure it's 1 meter by 1 meter by 1 meter max.

Any clue how much bigger? According to C4D it was within 50x50x50 cm. And turning it down to 0.5x0.5x0.5 cm still didn't seem to work. 

Are there any options when exporting the OBJ file? It might scale wrong.

Only options is scaling. Usually leave it at 1 cm, tried converting the entire model to mm, making it scale in mm when exporting to .obj , also tried scaling it all the way down to 0.1 mm, and it still doesn't appear in AssetForge.

This might help you a bit; the large cube is the file you originally posted and the tiny cube there is supposed to be 1 x 1 x 1 meter.

Jesus H.. But yeah, tried scaling it down to Nanometers as well, which is like 1/100000 of a millimeter in C4D. Will try opening it in Blender and get back to you. 

Ok, so something odd is happening with the scaling whenever C4D exports to .Obj as going through the process of exporting a different file format from C4D, opening it in Blender and then just exporting to a .obj file seems to solve it, a tedious process, but one I can live with. Thank you for all your help!

I was having issues with Modo obj export earlier. Asset Forge doesn't seem to like certain flags, like 'group'. Modo seems to want to always add a default group, so I opened the obj in a text editor and removed all group references and it worked fine.

.obj file format

In my case it\s simply the way C4D exports, opening the same .obj files in blender yields the same results as presented by Kenney above. Where it just scales really weirdly.