Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

For some reason it won't let me play Back alley slasher and Tuffum's lair, When I try to open either of them it just says "DX11 feature level 10.0 is required to run the engine." I'm not sure what that means.

(1 edit)

Upon a quick search online, that seems to be an error message caused by your hardware not supporting DX11 - UE4 switched from DX10 to DX11 in 2019. Both of these games use an updated version of Unreal as opposed to my older games using an earlier version. You could see if there's someway to update on your current system, but I'm not sure if you'd be able to.


Edit: Although I could be wrong! This may require new research, but it sounds like a driver update is necessary.

it sucks but dont worry boofies birthday adventure is the best­­­­

(1 edit)

Lol I already had that issue fixed a long time ago, I'm able to play the games now

oh ok