Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Tested under Lubuntu 19.10 64 bit with a graphics card that only supports OpenGL 2.x. Surprisingly worked with no issues. Well done.

Thanks.  This is good to hear.  We have been aiming our projects to support 32-bit systems with GLES2.  Our hope is to have things running nicely on the oldest drivers and hardware possible.